package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d*[0]{5}$`)
var str = `validate 100k * x`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}