$re = '/(\d+\s?)(px|in|)(\s+|$)/';
$str = '12 13px 13in 12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);