package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+\s?)(px|in|)(\s+|$)`)
var str = `12 13px 13in 12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}