// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\s[0-9]
|[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\-[0-9]
|[A-Z]{4}\s[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}\-[0-9]
|[A-Z]{4}[0-9]{6}[0-9]").unwrap();
let string = "ARKU 851 512 1
ARKU 851 512-1
ARKU 851512-1
ARKU851512-1
ARKU8515121
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}