#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\s[0-9]" & @CRLF & _
"|[A-Z]{4}\s[0-9]{3}+\s+[0-9]{3}\-[0-9]" & @CRLF & _
"|[A-Z]{4}\s[0-9]{6}\-[0-9]" & @CRLF & _
"|[A-Z]{4}[0-9]{6}\-[0-9]" & @CRLF & _
"|[A-Z]{4}[0-9]{6}[0-9]"
Local $sString = "ARKU 851 512 1" & @CRLF & _
"ARKU 851 512-1" & @CRLF & _
"ARKU 851512-1" & @CRLF & _
"ARKU851512-1" & @CRLF & _
"ARKU8515121" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")