import Foundation
let pattern = #"^(?<postcode>|(?<outward>(?<area>\w{1,2}))(?<district>\d\w|\d{1,2}))(?:\s)?(?<inward>(?<sector>\d)(?<unit>\w\w))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
W1J 7NT
DE12 8HJ
SW1A 1AA
HD7 5UZ
CH5 3QW
W2 1JB
PL7 1RF
EH99 1SB
G58 1SB
JE3 1EP
GIR 0AA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)