$re = '/^(?<postcode>|(?<outward>(?<area>\w{1,2}))(?<district>\d\w|\d{1,2}))(?:\s)?(?<inward>(?<sector>\d)(?<unit>\w\w))?/mi';
$str = 'W1J 7NT
DE12 8HJ
SW1A 1AA
HD7 5UZ
CH5 3QW
W2 1JB
PL7 1RF
EH99 1SB
G58 1SB
JE3 1EP
GIR 0AA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);