$re = '/(\p{Lu}$|\p{Lu}?\p{Ll}+|\p{Lu})/m';
$str = 'asdsdaaDasdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);