package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\p{Lu}$|\p{Lu}?\p{Ll}+|\p{Lu})`)
var str = `asdsdaaDasdasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}