$re = '/"{1}(.*?)"{1}/';
$str = 'this is a "" && "string constant" and this "is another" one
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);