package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"{1}(.*?)"{1}`)
var str = `this is a "" && "string constant" and this "is another" one
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}