use strict;
my $str = '0.0.0.0
192.168.1.1
127.0.0.1
255.255.255.255
256.0.0.0
0.256.0.0
0.0.256.0
0.0.0.256
.0.0.0.0
0.0.0.0.
';
my $regex = qr/(?:^|\s)
(\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b
\.
\b(?:2[0-4]\d|25[0-5]|1?\d?\d)\b)
(?:$|\s)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}