import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\s)\n"
+ "(\\b(?:2[0-4]\\d|25[0-5]|1?\\d?\\d)\\b\n"
+ "\\.\n"
+ "\\b(?:2[0-4]\\d|25[0-5]|1?\\d?\\d)\\b\n"
+ "\\.\n"
+ "\\b(?:2[0-4]\\d|25[0-5]|1?\\d?\\d)\\b\n"
+ "\\.\n"
+ "\\b(?:2[0-4]\\d|25[0-5]|1?\\d?\\d)\\b)\n"
+ "(?:$|\\s)";
final String string = "0.0.0.0\n"
+ "192.168.1.1\n"
+ "127.0.0.1\n"
+ "255.255.255.255\n\n\n"
+ "256.0.0.0\n"
+ "0.256.0.0\n"
+ "0.0.256.0\n"
+ "0.0.0.256\n"
+ ".0.0.0.0\n"
+ "0.0.0.0.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}