$re = '/^(?:[0-1][1-2])\/(?:[0-2]\d|3[0-1])$/m';
$str = '01/31
01/28
01/05
01/32
01/41';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);