const regex = /^(?:[0-1][1-2])\/(?:[0-2]\d|3[0-1])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-1][1-2])\\\/(?:[0-2]\\d|3[0-1])$', 'gm')
const str = `01/31
01/28
01/05
01/32
01/41`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}