re = /([a-zA-Z\:]){4,100}([a-zA-Z0-9]{8}[:-]([a-zA-Z0-9]{4}[:-]){3}[a-zA-Z0-9]{12})/
str = 'urn:vcloud:user:2998042f-b91d-4c16-9de8-7feaf5e711a8
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result