import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z\\:]){4,100}([a-zA-Z0-9]{8}[:-]([a-zA-Z0-9]{4}[:-]){3}[a-zA-Z0-9]{12})";
final String string = "urn:vcloud:user:2998042f-b91d-4c16-9de8-7feaf5e711a8\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}