re = /(?P<type>VIDEO)(?:::)(?P<desc>[\w#()\/-]*)?/m
str = 'VIDEO::INEOQUEST_SWITCH_A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end