package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<type>VIDEO)(?:::)(?P<desc>[\w#()/-]*)?`)
var str = `VIDEO::INEOQUEST_SWITCH_A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}