$re = '/(?<protokoll>[a-z]*):\/\/?(?<domain>[a-z.-]*)?(?<file>[^?#]*)?[?](?<parameter>[^#]*)?[#](?<anker>.*)?/';
$str = 'http://www.baumarkt.de/sub/kataloge.php?projekt=bm#start';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);