package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<protokoll>[a-z]*):\/\/?(?<domain>[a-z.-]*)?(?<file>[^?#]*)?[?](?<parameter>[^#]*)?[#](?<anker>.*)?`)
var str = `http://www.baumarkt.de/sub/kataloge.php?projekt=bm#start`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}