re = /insert[\s]+into[\s]+\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);/mi
str = 'insert into ( a, b, c ) values ( " insert into values (1,2,3)",1,2.3,"a,b" );
insert into (ee,bb,cc) values (aa,234,"asj",2.3);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end