#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)insert[\s]+into[\s]+\([\s]*(?<columns>.*?)[\s]*\)[\s]+values[\s]+\((?<values>.*?)[\s]*\);"
Local $sString = "insert into ( a, b, c ) values ( " insert into values (1,2,3)",1,2.3,"a,b" );" & @CRLF & _
"" & @CRLF & _
"insert into (ee,bb,cc) values (aa,234,"asj",2.3);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")