re = /[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?:[\s]*?[0-9]{3,6}/
str = '127 , 0 _ 0; 1 : 45345
zapraszamy na {1.2.3.1:4564}
ksk.sls.ss.ll:asas
121.121.12.11:4545
127 . 0 . 0 . 1 : 1234 asdasdsadafasdgdsfs sdfgsdfg
127 . 0 . 0. 1 : 45345 ksasdklasda ka sdk laksj dlkasj dlka sdlaksjd laksjd lkakjsdl ajksdl a
121.121.12.11:4545
127.0.0.1:1234
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end