use strict;
my $str = '127 , 0 _ 0; 1 : 45345
zapraszamy na {1.2.3.1:4564}
ksk.sls.ss.ll:asas
121.121.12.11:4545
127 . 0 . 0 . 1 : 1234 asdasdsadafasdgdsfs sdfgsdfg
127 . 0 . 0. 1 : 45345 ksasdklasda ka sdk laksj dlkasj dlka sdlaksjd laksjd lkakjsdl ajksdl a
121.121.12.11:4545
127.0.0.1:1234
';
my $regex = qr/[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?:[\s]*?[0-9]{3,6}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}