re = /^(?:[<>~+-]?\((?:(?:[<>~+-]?[\w][\w-]+[*]?|"[^"]+")(?:\s+(?:[<>~+-]?[\w][\w-]+[*]?|"[^"]+"))+)\)|[<>~+-]?[\w][\w-]+[*]?|"[^"]+")(?:\s+(?:[<>~+-]?\((?:(?:[<>~+-]?[\w][\w-]+[*]?|"[^"]+")(?:\s+(?:[<>~+-]?[\w][\w-]+[*]?|"[^"]+"))+)\)|[<>~+-]?[\w][\w-]+[*]?|"[^"]+"))*$/
str = '*'
# Print the match result
str.match(re) do |match|
puts match.to_s
end