$re = '/^(?:[<>~+-]?\((?:(?:[<>~+-]?[\w][\w-]+[*]?|"[^"]+")(?:\s+(?:[<>~+-]?[\w][\w-]+[*]?|"[^"]+"))+)\)|[<>~+-]?[\w][\w-]+[*]?|"[^"]+")(?:\s+(?:[<>~+-]?\((?:(?:[<>~+-]?[\w][\w-]+[*]?|"[^"]+")(?:\s+(?:[<>~+-]?[\w][\w-]+[*]?|"[^"]+"))+)\)|[<>~+-]?[\w][\w-]+[*]?|"[^"]+"))*$/';
$str = '*';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);