re = /^([^@\.;]+@[^@\.;]+\.[^@\.;]+[;]*)*[^@.;]+$/
str = 'cds@fewfwe.d;cds@fewfwe.d;cds@fewfwe.d;cds@fewfwe.d;cds@fewfwe.ddfr_'
# Print the match result
str.match(re) do |match|
puts match.to_s
end