$re = '/^([^@\.;]+@[^@\.;]+\.[^@\.;]+[;]*)*[^@.;]+$/';
$str = 'cds@fewfwe.d;cds@fewfwe.d;cds@fewfwe.d;cds@fewfwe.d;cds@fewfwe.ddfr_';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);