$re = '/[0-9]{8,10}/';
$str = '0123450000000000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);