const regex = /[0-9]{8,10}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{8,10}', '')
const str = `0123450000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}