$re = '/\+\d{1,2}-\d{3}-\d{3}-\d{4}/m';
$str = '+21-541-914-3010
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);