package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+\d{1,2}-\d{3}-\d{3}-\d{4}`)
var str = `+21-541-914-3010
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}