$re = '/[ a-zA-Z0-9]+/mi';
$str = 'Gä123Ätnerei Hau?sß 123\'^#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);