package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[ a-zA-Z0-9]+`)
var str = `Gä123Ätnerei Hau?sß 123'^#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}