$re = '/^(\d{1,2})[:. ]?(\d{0,2})[:. ]?(\d{0,2})[:. ]?([ap]?\.?m\.?)?/im';
$str = '09:00:00
9:15
9.15
15:10
15:10:32
3:10 p.m.
3:10 pm
03:10:32 pm
10 am
10 a.m.
10am
10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);