#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(\d{1,2})[:. ]?(\d{0,2})[:. ]?(\d{0,2})[:. ]?([ap]?\.?m\.?)?"
Local $sString = "09:00:00" & @CRLF & _
"9:15" & @CRLF & _
"9.15" & @CRLF & _
"15:10" & @CRLF & _
"15:10:32" & @CRLF & _
"3:10 p.m." & @CRLF & _
"3:10 pm" & @CRLF & _
"03:10:32 pm" & @CRLF & _
"10 am" & @CRLF & _
"10 a.m." & @CRLF & _
"10am" & @CRLF & _
"10" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")