# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(Sensor #0 -> (?P<EXT>\d+[.]\d+)(?:.*?Sensor #2 -> )(?P<INT>\d+[.]\d+)(?:.*?)(?P<DATE>\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}))"
test_str = ("system tmp gettemp 0\n"
"Sensor #0 -> 69.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 87.81 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:50system tmp gettemp 0\n"
"Sensor #0 -> 69.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 88.110 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:51system tmp gettemp 0\n"
"Sensor #0 -> 69.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 88.206 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:52system tmp gettemp 0\n"
"Sensor #0 -> 69.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 87.176 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:53system tmp gettemp 0\n"
"Sensor #0 -> 69.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 88.110 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:54system tmp gettemp 0\n"
"Sensor #0 -> 69.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 88.110 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:55system tmp gettemp 0\n"
"Sensor #0 -> 69.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 87.176 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:56system tmp gettemp 0\n"
"Sensor #0 -> 69.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 87.81 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:57system tmp gettemp 0\n"
"Sensor #0 -> 68.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 88.15 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:58system tmp gettemp 0\n"
"Sensor #0 -> 68.0 \n\n"
"OK\n"
"dbg_cpu0> system tmp gettemp 2\n"
"Sensor #2 -> 88.15 \n\n"
"OK\n"
"dbg_cpu0> \n"
"dbg_cpu0> 2016/11/23 11:04:59system tmp gettemp 0\n"
"Sensor #0 -> 68.0 \n\n"
"OK\n"
"dbg_cpu0> 2016/11/23 11:05:002016/11/23 11:05:012016/11/23")
matches = re.finditer(regex, test_str, re.DOTALL | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.