#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^(Sensor #0 -> (?P<EXT>\d+[.]\d+)(?:.*?Sensor #2 -> )(?P<INT>\d+[.]\d+)(?:.*?)(?P<DATE>\d{4}\/\d{2}\/\d{2}\s+\d{2}:\d{2}:\d{2}))"
Local $sString = "system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 69.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 87.81 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:50system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 69.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 88.110 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:51system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 69.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 88.206 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:52system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 69.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 87.176 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:53system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 69.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 88.110 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:54system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 69.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 88.110 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:55system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 69.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 87.176 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:56system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 69.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 87.81 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:57system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 68.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 88.15 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:58system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 68.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> system tmp gettemp 2" & @CRLF & _
"Sensor #2 -> 88.15 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> " & @CRLF & _
"dbg_cpu0> 2016/11/23 11:04:59system tmp gettemp 0" & @CRLF & _
"Sensor #0 -> 68.0 " & @CRLF & _
"" & @CRLF & _
"OK" & @CRLF & _
"dbg_cpu0> 2016/11/23 11:05:002016/11/23 11:05:012016/11/23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")