re = /^(.*@\/component[^.;]*?)(?!\.vue)['"];?$/m
str = 'import SmartLink from \'@/components/smartLink\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end