$re = '/^(.*@\/component[^.;]*?)(?!\.vue)[\'"];?$/m';
$str = 'import SmartLink from \'@/components/smartLink\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);