$re = '/^(?:(?!end).)*start.*/m';
$str = 'line_end; start
line start; end
';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;