use strict;
my $str = 'line_end; start
line start; end
';
my $regex = qr/^(?:(?!end).)*start.*/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";