import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s{1,}\\S{1,}$";
final String string = "ITGIS.COMP_OP_STN cos\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "ITGIS.COMP_OP_STN cos\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "ITGIS.COMP_OP_STN cos\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "ITGIS.COMP_OP_STN cos\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "ITGIS.COMP_OP_STN cos\n"
+ "nsdMatches nsd\n"
+ "nrzMatches nrz\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "ITGIS.NS_DIVISIONS nd\n"
+ "NFSAPP.CONTROL nfsac\n"
+ "PUBDATA.US_CITIES c\n"
+ "ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "ENGXING.DOTLIST dl\n"
+ "INNER JOIN ENGXING.CI_LOCATIONANDCLASSIFICATION cils\n"
+ "ENGXING.INVENTORY_QUE q\n"
+ "nsdMatches nsd\n"
+ "ENGXING.CI_OPERATINGRAILROAD cior\n"
+ "nrzMatches nrz\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "ITGIS.NS_DIVISIONS nd\n"
+ "ENG.ENG_CROSSING ec\n"
+ "NFSAPP.CONTROL nfsac\n"
+ "PUBDATA.US_CITIES c\n"
+ "EGIS.ENG_MPMARK mp\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "EGIS.ENG_MPMARK mp\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "EGIS.ENG_MPMARK mp\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "EGIS.ENG_MPMARK mp\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "EGIS.ENG_MPMARK mp\n"
+ "nrzMatches nrz\n"
+ "nsdMatches nsd\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "ITGIS.NS_DIVISIONS nd\n"
+ "NFSAPP.CONTROL nfsac\n"
+ "PUBDATA.US_CITIES c\n"
+ "EGIS.ENG_SWITCH s\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "EGIS.ENG_SWITCH s\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "EGIS.ENG_SWITCH s\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "EGIS.ENG_SWITCH s\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "EGIS.ENG_SWITCH s\n"
+ "nsdMatches nsd\n"
+ "nrzMatches nrz\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "ITGIS.NS_DIVISIONS nd\n"
+ "NFSAPP.CONTROL nfsac\n"
+ "PUBDATA.US_CITIES c\n"
+ "EGIS.ENG_TOWER t\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "EGIS.ENG_TOWER t\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "EGIS.ENG_TOWER t\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "EGIS.ENG_TOWER t\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "EGIS.ENG_TOWER t\n"
+ "nsdMatches nsd\n"
+ "nrzMatches nrz\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "ITGIS.NS_DIVISIONS nd\n"
+ "PUBDATA.US_CITIES c\n"
+ "ITGIS.COMP_AEI_SCNR s\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "ITGIS.COMP_AEI_SCNR s\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "ITGIS.COMP_AEI_SCNR s\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "ITGIS.COMP_AEI_SCNR s\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "ITGIS.COMP_AEI_SCNR s\n"
+ "nsdMatches nsd\n"
+ "nrzMatches nrz\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "ITGIS.NS_DIVISIONS nd\n"
+ "NFSAPP.CONTROL nfsac\n"
+ "PUBDATA.US_CITIES c\n"
+ "ITGIS.NSPD_LOCATIONS l\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "ITGIS.NSPD_LOCATIONS l\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "ITGIS.NSPD_LOCATIONS l\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "ITGIS.NSPD_LOCATIONS l\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "ITGIS.NSPD_LOCATIONS l\n"
+ "nsdMatches nsd\n"
+ "nrzMatches nrz\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "PUBDATA.US_CITIES c\n"
+ "NSPD.NSPD_POI poi\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "NSPD.NSPD_POI poi\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "NSPD.NSPD_POI poi\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "NSPD.NSPD_POI poi\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "NSPD.NSPD_POI poi\n"
+ "nsdMatches nsd\n"
+ "nrzMatches nrz\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "PUBDATA.US_CITIES c\n"
+ "ITGIS.ITGIS_MP100S mp\n"
+ "ITGIS.NS_DIVISIONS nsd\n"
+ "ITGIS.ITGIS_MP100S mp\n"
+ "ITGIS.NSPD_RESP_ZONE nrz\n"
+ "ITGIS.ITGIS_MP100S mp\n"
+ "PUBDATA.US_COUNTIES usc\n"
+ "ITGIS.ITGIS_MP100S mp\n"
+ "PUBDATA.US_CITIES_BOUNDARIES uscb\n"
+ "ITGIS.ITGIS_MP100S mp\n"
+ "NFSAPP.CONTROL nfsac\n"
+ "nrzMatches nrz\n"
+ "nsdMatches nsd\n"
+ "cityBoundaryMatches\n"
+ "countyMatches\n"
+ "ITGIS.NSPD_LOCATIONS nl\n"
+ "ITGIS.NS_DIVISIONS nd\n"
+ "PUBDATA.US_CITIES c\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}