#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s{1,}\S{1,}$"
Local $sString = "ITGIS.COMP_OP_STN cos" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"ITGIS.COMP_OP_STN cos" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"ITGIS.COMP_OP_STN cos" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"ITGIS.COMP_OP_STN cos" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"ITGIS.COMP_OP_STN cos" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"ITGIS.NS_DIVISIONS nd" & @CRLF & _
"NFSAPP.CONTROL nfsac" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
"ENGXING.CI_LOCATIONANDCLASSIFICATION cils" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"ENGXING.CI_LOCATIONANDCLASSIFICATION cils" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"ENGXING.CI_LOCATIONANDCLASSIFICATION cils" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"ENGXING.CI_LOCATIONANDCLASSIFICATION cils" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"ENGXING.DOTLIST dl" & @CRLF & _
"INNER JOIN ENGXING.CI_LOCATIONANDCLASSIFICATION cils" & @CRLF & _
"ENGXING.INVENTORY_QUE q" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"ENGXING.CI_OPERATINGRAILROAD cior" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"ITGIS.NS_DIVISIONS nd" & @CRLF & _
"ENG.ENG_CROSSING ec" & @CRLF & _
"NFSAPP.CONTROL nfsac" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
"EGIS.ENG_MPMARK mp" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"EGIS.ENG_MPMARK mp" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"EGIS.ENG_MPMARK mp" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"EGIS.ENG_MPMARK mp" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"EGIS.ENG_MPMARK mp" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"ITGIS.NS_DIVISIONS nd" & @CRLF & _
"NFSAPP.CONTROL nfsac" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
"EGIS.ENG_SWITCH s" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"EGIS.ENG_SWITCH s" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"EGIS.ENG_SWITCH s" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"EGIS.ENG_SWITCH s" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"EGIS.ENG_SWITCH s" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"ITGIS.NS_DIVISIONS nd" & @CRLF & _
"NFSAPP.CONTROL nfsac" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
"EGIS.ENG_TOWER t" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"EGIS.ENG_TOWER t" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"EGIS.ENG_TOWER t" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"EGIS.ENG_TOWER t" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"EGIS.ENG_TOWER t" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"ITGIS.NS_DIVISIONS nd" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
"ITGIS.COMP_AEI_SCNR s" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"ITGIS.COMP_AEI_SCNR s" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"ITGIS.COMP_AEI_SCNR s" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"ITGIS.COMP_AEI_SCNR s" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"ITGIS.COMP_AEI_SCNR s" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"ITGIS.NS_DIVISIONS nd" & @CRLF & _
"NFSAPP.CONTROL nfsac" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
"ITGIS.NSPD_LOCATIONS l" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"ITGIS.NSPD_LOCATIONS l" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"ITGIS.NSPD_LOCATIONS l" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"ITGIS.NSPD_LOCATIONS l" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"ITGIS.NSPD_LOCATIONS l" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
"NSPD.NSPD_POI poi" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"NSPD.NSPD_POI poi" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"NSPD.NSPD_POI poi" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"NSPD.NSPD_POI poi" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"NSPD.NSPD_POI poi" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
"ITGIS.ITGIS_MP100S mp" & @CRLF & _
"ITGIS.NS_DIVISIONS nsd" & @CRLF & _
"ITGIS.ITGIS_MP100S mp" & @CRLF & _
"ITGIS.NSPD_RESP_ZONE nrz" & @CRLF & _
"ITGIS.ITGIS_MP100S mp" & @CRLF & _
"PUBDATA.US_COUNTIES usc" & @CRLF & _
"ITGIS.ITGIS_MP100S mp" & @CRLF & _
"PUBDATA.US_CITIES_BOUNDARIES uscb" & @CRLF & _
"ITGIS.ITGIS_MP100S mp" & @CRLF & _
"NFSAPP.CONTROL nfsac" & @CRLF & _
"nrzMatches nrz" & @CRLF & _
"nsdMatches nsd" & @CRLF & _
"cityBoundaryMatches" & @CRLF & _
"countyMatches" & @CRLF & _
"ITGIS.NSPD_LOCATIONS nl" & @CRLF & _
"ITGIS.NS_DIVISIONS nd" & @CRLF & _
"PUBDATA.US_CITIES c" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")