import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:31(\\/|-|\\.)(?:0?[13578]|1[02]))\\1|(?:(?:29|30)(\\/|-|\\.)(?:0?[13-9]|1[0-2])\\2))(?:(?:1[6-9]|[2-9]\\d)?\\d{2})$|^(?:29(\\/|-|\\.)0?2\\3(?:(?:(?:1[6-9]|[2-9]\\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:0?[1-9]|1\\d|2[0-8])(\\/|-|\\.)(?:(?:0?[1-9])|(?:1[0-2]))\\4(?:(?:1[6-9]|[2-9]\\d)?\\d{2})$";
final String string = "16/10/1991\n"
+ "16-10-1991\n"
+ "16.10.1991\n"
+ "1991/16/10\n"
+ "1991-16-10\n"
+ "1991.16.10\n"
+ "10/16/1991\n"
+ "10-16-1991\n"
+ "10.16.1991\n\n"
+ "01/01/2000\n"
+ "31/01/2000\n"
+ "32/01/2000\n"
+ "01/1/2000\n"
+ "01/1/01\n\n"
+ "29/02/2000\n"
+ "28/02/2001\n"
+ "29/02/2003\n\n"
+ "30/04/2000\n"
+ "31/04/2000\n\n"
+ "31/07/2000\n\n"
+ "31/08/2000\n\n"
+ "31/09/2000\n\n"
+ "01/12/2000\n\n"
+ "01/15/2000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}