#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:31(\/|-|\.)(?:0?[13578]|1[02]))\1|(?:(?:29|30)(\/|-|\.)(?:0?[13-9]|1[0-2])\2))(?:(?:1[6-9]|[2-9]\d)?\d{2})$|^(?:29(\/|-|\.)0?2\3(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:0?[1-9]|1\d|2[0-8])(\/|-|\.)(?:(?:0?[1-9])|(?:1[0-2]))\4(?:(?:1[6-9]|[2-9]\d)?\d{2})$"
Local $sString = "16/10/1991" & @CRLF & _
"16-10-1991" & @CRLF & _
"16.10.1991" & @CRLF & _
"1991/16/10" & @CRLF & _
"1991-16-10" & @CRLF & _
"1991.16.10" & @CRLF & _
"10/16/1991" & @CRLF & _
"10-16-1991" & @CRLF & _
"10.16.1991" & @CRLF & _
"" & @CRLF & _
"01/01/2000" & @CRLF & _
"31/01/2000" & @CRLF & _
"32/01/2000" & @CRLF & _
"01/1/2000" & @CRLF & _
"01/1/01" & @CRLF & _
"" & @CRLF & _
"29/02/2000" & @CRLF & _
"28/02/2001" & @CRLF & _
"29/02/2003" & @CRLF & _
"" & @CRLF & _
"30/04/2000" & @CRLF & _
"31/04/2000" & @CRLF & _
"" & @CRLF & _
"31/07/2000" & @CRLF & _
"" & @CRLF & _
"31/08/2000" & @CRLF & _
"" & @CRLF & _
"31/09/2000" & @CRLF & _
"" & @CRLF & _
"01/12/2000" & @CRLF & _
"" & @CRLF & _
"01/15/2000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")