$re = '/(^|\s)\S/';
$str = 'foobarr bla wkwk i\'am';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);