package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|\s)\S`)
var str = `foobarr bla wkwk i'am`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}