$re = '/([A-Z]{2}[a-zA-Z0-9]+)/m';
$str = 'CY99999999L sts wtr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);